Skip to content Skip to sidebar Skip to footer

CVE-2020-27207 – Zetetic SQLCipher 4.x before 4.4.1 has a use-after-free, related to sqlci

Zetetic SQLCipher 4.x before 4.4.1 has a use-after-free, related to sqlcipher_codec_pragma and sqlite3Strlen30 in sqlite3.c. A remote denial of service attack can be performed. For example, a SQL injection can be used to execute the crafted SQL command sequence. After that, some unexpected RAM data is read.

 

Source: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-27207

Reference (s):

  • https://github.com/sqlcipher/sqlcipher/compare/v4.4.0…v4.4.1
  • https://www.telekom.com/en/corporate-responsibility/data-protection-data-security/security/details/advisories-504842
  • https://www.telekom.com/resource/blob/612796/9f221708832a465f03585a45d7f59b45/dl-201112-denial-of-serviceen-data.pdf

Sign Up to Our Newsletter

Be the first to know the latest updates